> Can this be installed over the current version or is it better to
> uninstall 180 first?

No, it should be fine to just install over  the current version.