I posted something about it on my blog recently, after a recent OS X  
update screwed up my $PATH
That's something you need to spend the time looking into.
The one-click installer may or may not replace the old Ruby, but the  
Hivelogic install directions will get you what you want.
Don't worry though, only 1 more likely update to OS X 10.4 (10.4.11)  
and 10.5 will be out with a working Ruby.
You should install the mongrel gem though. It makes a much more  
responsive test server with the built in apache. (and you don't have  
to turn apache off to use it, and most hosts providing shell access  
and ruby/rails will be on apache anyway.
The book Rails Solutions, from Friends of ED, has an excellent  
install/setup for Ruby and Rails in it.