On Wed, 19 Sep 2007 03:20:07 +0900, castillo.bryan / gmail.com wrote:
> I received the error with the stable recommended version from
> http://www.ruby-lang.org/en/downloads/.

Hmm.  It looks like that is different from p36 (the file size is different):

  ftp://ftp.ruby-lang.org/pub/ruby/1.8/

Try the -p36 tarball and see if it makes a difference (it should, based
on others' experience).

Perhaps someone running the site needs to be more diligent about what is
offered for download.

-mental