> There is bunch of wiki pages with a lot of information about hopefully
> everything important:
> 
> http://wiki.netbeans.org/wiki/view/Ruby
> 
> in this case, particularly:
> 
> http://wiki.netbeans.org/wiki/view/RubyInstallation
> 
> But as James said M10 is really ancient and better to use a piece from:
> 
> http://deadlock.netbeans.org/hudson/job/ruby/
> 
> If you encounter any problem let us know:
> 
> http://wiki.netbeans.org/wiki/view/RubyFeedback
> 
> Or contact directly. Feedback is always appreciated.
> 
> Regards,
>   m.

Ok.
When I say that there's not many information, I mean not beeing able to 
find good information from "non-official" channels. I mean, in a place 
like the Internet what you gave me is not "a lot of" nothing. But, of 
course, we're talking about new things, Netbeans 6 is very new, so we 
canĀ“t expect a lot of specialized information...but not in the case of 
Eclipse! But please, let me say again that I'm no expert so I (probably) 
could have "thrown" away some good information that crossed me, just 
because it seemed very complicated to me :(

So, I went to the pages you gave me.
There it says that if I want to use native ruby, there's only one simple 
thing to do: go to the options and select the ruby interpreter. I've 
already done this.
By the way, I have ruby 1.8.6 installed. (In C:\ruby) Dont know if this 
is important.

To update, i followed what is said in 
http://wiki.netbeans.org/wiki/view/RubyInstallation#section-RubyInstallation-ConfiguringTheUpdateCenter
but i still had no updates in the Netbeans' plugin manager.
So I'm thinking i have the latest release of what I have installed.

I noticed something in that same page, when talking about gems
http://wiki.netbeans.org/wiki/view/RubyInstallation#section-RubyInstallation-InstallingNativeRuby
it says that the IDE must have write permissions so we can use gem 
manager with native ruby.
Might this be my problem? I mean, when trying to run ruby, netbeans does 
not have write permissions and so i cant run ruby programs??
If so, what should I do? Is this the same problem with Eclipse?

Thank you.

-- 
Posted via http://www.ruby-forum.com/.