------art_121960_7580072.1188264180088
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

So do..

output  ystem`'sh ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg
Ubuntu/feisty'`


On 8/27/07, kazaam <kazaam / oleco.net> wrote:
>
> it is executable and working with
> system('sh ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg
> Ubuntu/feisty')
> system('./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg
> Ubuntu/feisty | cat-')
> but not with
> system('./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg
> Ubuntu/feisty')
>
> and noone has any explaination for this behavior of system?
>
>
> On Mon, 27 Aug 2007 23:22:51 +0900
> "Felix Windt" <fwmailinglists / gmail.com> wrote:
>
> > > -----Original Message-----
> > > From: kazaam [mailto:kazaam / oleco.net]
> > > Sent: Monday, August 27, 2007 7:05 AM
> > > To: ruby-talk ML
> > > Subject: Re: Why does:
> > > system("./ati-driver-installer-8.40.4-x86.x86_64.run
> > > --buildpkg Ubuntu/feisty") not work ? It always fails without
> > > any error?
> > >
> > > Okay I did as suggested:
> > >
> > > #!/usr/bin/env ruby
> > > $Verboseue
> > >    response  ./ati-driver-installer-8.40.4-x86.x86_64.run
> > > --buildpkg Ubuntu/feisty`
> > >    puts response
> > >
> > > outputs:
> > >    ./test.rb:6: command not found:
> > > ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg Ubuntu/feisty
> > > but the same with
> > >    response  sh
> > > ./ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg Ubuntu/feisty`
> > > is working correctly?
> > >
> > > Is this a bug?
> > > --
> > > kazaam <kazaam / oleco.net>
> > >
> >
> > No, that most likely means that ati-driver-install-... is not an
> executable
> > file.
> >
> > Either set the executable flag via chmod, or just pass it as an argument
> to
> > sh as is working for you.
> >
> > Felix
> >
>
>
> --
> kazaam <kazaam / oleco.net>
>
>

------art_121960_7580072.1188264180088--