Hi,

2007/8/17, Clif Smith <cjs226 / yahoo.com>:
> I'm trying to get ruby running on AIX 5.3 as I can't find any precompiled versions...  ;-)
<snip>
> /opt/freeware/lib/gcc/powerpc-ibm-aix5.1.0.0/4.0.0/include/wchar.h:299: error: parse error before 'mbstate_t'
> /opt/freeware/lib/gcc/powerpc-ibm-aix5.1.0.0/4.0.0/include/wchar.h:302: error: parse

It seemed that you've installed gcc for AIX 5.1 to AIX 5.3.
I was able to recreate this error using gcc for 5.1 in my test
environment(AIX5.3).
Please install correct version of gcc.
You can download them from
ftp://ftp.software.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc

Regards,
 --
Yutaka KANEMOTO
http://d.hatena.ne.jp/kinpoco/