So, for anyone who remembers, I had a post a while ago about not being
to get into console with Rails. I kept getting this error saying error
with custom require. I tried uninstalling rails and reinstalling, using
the latest and earlier versions. I uninstalled ruby and reinstalled with
1.8.6. Tried 1.8.5. still nothing. Well, I am trying out this video game
development framework called shattered ruby, and I can't run ruby
script/runner without getting a similar error.

C:\shattered_apps\dirty_ruby>ruby script/runner
c:/ruby/lib/ruby/gems/1.8/gems/shattered_ogrerb-0.5.0.2/vendor/ogrerb/lib/ogre.d
ll: 14001: This application has failed to start because the application
configur
ation is incorrect. Reinstalling the application may fix this problem.
- c:/ru
by/lib/ruby/gems/1.8/gems/shattered_ogrerb-0.5.0.2/vendor/ogrerb/lib/ogre.dll
(L
oadError)
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from
c:/ruby/lib/ruby/gems/1.8/gems/shattered_ogrerb-0.5.0.2/lib/../vend
or/ogrerb/ogre.rb:9
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from
c:/ruby/lib/ruby/gems/1.8/gems/shattered_ogrerb-0.5.0.2/lib/shatter
ed_ogrerb.rb:13
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `ge
m_original_require'
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire'
        from
c:/ruby/lib/ruby/gems/1.8/gems/shattered_ruby-0.5.0.2/lib/shatter.r
b:4
         ... 6 levels...
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from ./script/runner.rb:2:in `start_game'
        from script/runner:8

The rails error, though shorter, still mentions the custom_require.rb
file

Loading development environment.
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_re
quire': no such file to load -- ./script/../config/../config/environment
(LoadEr
ror)
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from c:/ruby/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
        from c:/ruby/lib/ruby/1.8/irb/init.rb:250:in `each'
        from c:/ruby/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
        from c:/ruby/lib/ruby/1.8/irb/init.rb:21:in `setup'
        from c:/ruby/lib/ruby/1.8/irb.rb:54:in `start'
        from c:/ruby/bin/irb.bat:15



PLEASE!!! I need help so bad, i'm getting frustrated. Thanks so much.


~Jeremy
-- 
Posted via http://www.ruby-forum.com/.