While updating my gem collection I have receive unpleasant info :-(

Attempting remote update of windows-pr
ERROR:  While executing gem ... (OpenURI::HTTPError)
    404 Not Found

I try many times and even try gem update -- system, but without any
lack.

C:\ruby>ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-mswin32]

C:\ruby>gem -v
0.9.4

Any solution besides installing the ruby and all my gems again?