I compiled ruby-fltk in microsoft visual C++ 5.0 and installed the resulting
rubyfltk.dll in C:\cygwin\usr\local\lib\ruby\1.6\i386-cygwin and removed the
old rubyfltk.so file.

When I do "require 'rubyfltk.dll'" I get this error:

	in `require': dlopen: Win32 error 126 -
/usr/local/lib/ruby/1.6/i386-cygwin/rubyfltk.dll (LoadError)

What could cause this error?  Is the cygwin compiled version of Ruby
compatible with DLL files?