> I'm using libhpricot-ruby1.8 with Ubuntu...

When in doubt, blame Debian's clumsy Ruby packaging. The out-of-the box 
Hpricot was 4.1 (with notorious bugs in the search, etc.).

Upgrading to this one provides the native inner_text:

http://archive.ubuntu.com/ubuntu/pool/universe/libh/libhpricot-ruby/libhpricot-ruby1.8_0.5-2_i386.deb

-- 
 Phlip
 http://www.oreilly.com/catalog/9780596510657/
 "Test Driven Ajax (on Rails)"
 assert_xpath, assert_javascript, & assert_ajax