On Aug 3, 3:13 pm, gregarican <greg.kuj... / gmail.com> wrote:
> On Aug 3, 2:56 pm, "Sy Ali" <sy1... / gmail.com> wrote:
>
> > I'm happy with the older ruby 1.8.4 which I have for my Zaurus
> > SL-C1000.  I can finally get rubygems up and running and with that
> > many other gems.. but I cannot get ncurses working.
>
> > This is because ncurses is expecting the ruby development libraries,
> > which I cannot find anywhere.
>
> > Does anyone have any ideas as to how I could get enough of a
> > ruby-devel installed to get ncurses working?
>
> Good question. Several years ago I did some Ruby programming on a
> SL-5500. I can't recall how complete of an install it was. Most likely
> bare-bones. And trying to cross compile Ruby for the Zaurus turned
> into a train wreck due to my own ignorance. I'll check my files and
> see what all I was able to do back then...

I have Ruby 1.8.3 on my SL-5500 and it appears as if ruby-devel is on
there. I see libruby.so and other so files. If that's the case then
perhaps scope out http://shimi.info/modules/bwiki/index.php?cmd=read&page=Zaurus%2FRuby
which is a site that links to an IPK for this version. If it doesn't
appear complete then e-mail me and I can send you the IPK from my
Zaurus.

>From what I remember I had some fun developing on the Z. Had Python,
Ruby, and Squeak all running on it at one time or the other :-)