On Aug 2, 4:10 pm, "ronald braswell" <rpbrasw... / hotmail.com> wrote:
> Will there be a compatability flag to allow1.9to act like 1.8 for cases in
> which backwards compatability was broken?  That way you could take advantage
> of new features w/o having to rewrite an existing codebase all at once.
>
> Ron

That way lies the Perl path.

Don't get me wrong. I came to Ruby from Perl and I enjoyed it just
fine, but I'm much happier with Ruby. There are some things I don't
entirely agree with, but some of those are changing with 1.9. They're
changing to be better, which leads to breaking some code that depends
on the old behavior. Backwards compatibility is nice, but it's not so
important that you hobble progress.

--
-yossef