On 8/1/07, Ari Brown <ari / aribrown.com> wrote:

> > Because gem() doesn't require anything.
>
> Bwah? But I've used it before! How can this be?

This behaviour has been on the way out since before 0.9.0.  Just use:

require "rubygems"
require "active_record"

gem() is meant to be used only to lock a gem to a specific version,
not to load a library.

As far as the warnings go, it's because the Rails core team is too
cool for ruby -w  :-/