Seshu Vaddi wrote:

> I downloaded the Ruby source ruby-1.8.6. I compiled the source and
> installed. But the GUI tool kit TK is not binding and throwing an error
> on executing an .rb file, like
> "HelloWorld.rb:1:in `require': no such file to load -- tk (LoadError)"

Don't compile Ruby. There's some system to add tk support when you
compile; don't bother. Just install Ruby and a matching RubyTk library
from your distro.

On my Ubuntu, I search up the correct package like this:

  apt-cache search ruby | grep -i tk

then install it like this:

  sudo apt-get install libtk-ruby

Uninstall whatever you did, first, then use your platform's package
manager to install a complete set of integrated packages.

-- 
 Phlip
 http://www.oreilly.com/catalog/9780596510657/
 ^ assert_xpath
 http://tinyurl.com/yrc77g  <-- assert_latest Model