Chirag Mistry wrote:
> Yukihiro Matsumoto wrote:
>> Hi,
>> 
>> In message "Re: Problem in compilation and installation of Ruby 1.9"
>>     on Thu, 12 Jul 2007 23:52:14 +0900, Chirag Mistry 
>> <chirag80bece / gmail.com> writes:
>> 
>> |> Upgrade your ruby before compiling trunk.
>> 
>> |     Thanks for the reply. I have installed ruby 1.8.6 which is 
>> |installed under "/usr/local". The older version ruby 1.6.8 is still in 
>> |"/usr". the "ruby" command now upgraded with /usr/local/bin/ruby which 
>> |latest ruby 1.8.6. But still I am getting below error. Please give your 
>> |feedback.
>> 
>> So your build process must be kicking old ruby (1.6.8?).  Try checking
>> your PATH priority or specify BASERUBY for your make, e.g.
>> 
>>   make BASERUBY=/usr/local/bin/ruby
>> 
>>               matz.
> 
> Hi Matz
>     I tried it also but it is still not wroking. I am getting same 
> error.

Hi
    I checked the things whatever you had mentioned in your reply and 
then I tried but it displayed same error. Then I have completely 
uninstalled older version of ruby-1.6.8 and then install 1.8.6. Then I 
tried to compile ruby1.9 package. But it is still giving same error and 
???make??? fails at the execution of following command:

./miniruby  ./mkconfig.rb -timestamp=.rbconfig.time -install_name=ruby 
-so_name=ruby rbconfig.rb

Are there any special settings to compile ruby1.9 package?
Are there any prerequisites for successful compilation of ruby1.9 
package?


-- 
Posted via http://www.ruby-forum.com/.