> rbuic mainWindow.ui > mainWindow.rb

You're mixing QtRuby versions here.  The rbuic you are using is for QtRuby for Qt3. 
You probably need to use rbuic4 (that's what it's called on my system).

Caleb