Axel Etzold wrote:
> Dear all,
>
> I am having problems installing rsruby, the bindings for the
> R statistical language.
> I am on an OpenSuSE 10.2, 64 bit system.
> It looked at first that everything in the
> installation went smoothly, ie the installation of R
> itself from binaries, and the installation of rsruby
> (I tried both the gems and the source code, successively),
> following the instructions on sciruby
>
> http://sciruby.codeforpeople.com/sr.cgi/RubyWithRlang .
>
> But when I try to run some code, as in the example provided
> on that page, I get:
>
> /usr/local/lib/ruby/site_ruby/1.8/x86_64-linux/rsruby.so: libRblas.so: cannot open shared object file: No such file or directory - /usr/local/lib/ruby/site_ruby/1.8/x86_64-linux/rsruby.so (LoadError)
> 	from /usr/local/lib/ruby/site_ruby/1.8/rsruby.rb:2
> 	from r001.rb:2:in `require'
> 	from r001.rb:2
>
> 'ls' tells me that the file is there...
> I have tried appending the path, setting symbolic links, 
> no result.
>
> What's going wrong? Why don't I see it?
>   
I hate this message. It's very confusing. The loader is complaining that 
it has loaded rsruby.so, but rsruby.so needs libRblas.so and the loader 
can't find libRblas.so.

Probably you have installed libRblas.so in /usr/local/lib. Make sure you 
have /usr/local/lib (or whatever directory libRblas.so is in) in your 
LD_LIBRARY_PATH. Check out man ld.so(8) for more information about 
LD_LIBRARY_PATH.

-- 
RMagick OS X Installer [http://rubyforge.org/projects/rmagick/]
RMagick Hints & Tips [http://rubyforge.org/forum/forum.php?forum_id=1618]
RMagick Installation FAQ [http://rmagick.rubyforge.org/install-faq.html]