Hi,

At Wed, 11 Jul 2007 18:15:13 +0900,
Chirag Mistry wrote in [ruby-talk:258763]:
> Machine/OS information for my machine:
> OS: GNU/Linux
> Kernel: 2.4.21-40.ELsmp
> Kernel Version: #1 SMP Thu Feb 2 22:22:39 EST 2006
> Processor: i686
> Hardware-platform - i386

What's the version of gcc?

> First I got this error:
> ---
> rm -f ruby
> /opt/ruby/ruby-1.8.6/ruby ./tool/insns2vm.rb --srcdir="."
> ./tool/insns2vm.rb:3:in `require': no such file to load -- optparse
> (LoadError)
>         from ./tool/insns2vm.rb:3

How did you install that ruby without optparse.rb?

> The next error I got was:
> ---
> In file included from thread.c:150:
> thread_pthread.ci:90:1: directives may not be used inside a macro
> argument
> thread_pthread.ci:89:65: unterminated argument list invoking macro
> "NOINLINE"

I haven't seen this error, it may be a gcc version issue.
Anyway, I hope this has been fixed now.

> I was getting a below warning for many of the files:
> ---
> yarvcore.h:614: warning: `fastcall' attribute directive ignored
> ---

What's the version of autoconf?  The warning should be checked
in configure.in.

-- 
Nobu Nakada