Hi,

In message "Re: Yield should be renamed call_block"
    on Tue, 10 Jul 2007 00:55:04 +0900, dblack / wobblini.net writes:

|If this ends up happening, I would (reluctantly) suggest getting rid
|of "yield", and just use call.  b.yield, as others have pointed out,
|doesn't really work semantically: the function isn't yielding, it's
|being yielded *to*.

Since I am not a English speeker and I usually dont use that particlar
word, I feel like "yield" as rather like a symbol vaguly related to
passing valu to the blok.

Besides that, receivers often plays subjective roles for verbs (method
names), for example thread.kill or file.close, etc.

							matz.