Hi --

On Mon, 9 Jul 2007, Yukihiro Matsumoto wrote:

> Hi,
>
> In message "Re: Yield should be renamed call_block"
>    on Mon, 9 Jul 2007 09:10:23 +0900, Bharat Ruparel <bruparel / mercury.com> writes:
>
> |I find it fascinating and quite a bit true.  However, I have to always
> |mentally translate the keyword "yeild" to mean "call_block".
>
> The "yield" keyword is used for this purpose from the ages of
> languages for example in CLU.  So if you learn the history and the
> culture, you will find less problem.
>
> I am not going to rename it.  But in far future (3.0? maybe), the
> keyword will be removed from the language, and you will access blocks
> via block arguments of methods.

I'm curious what the rationale is for that.  Also, will the block
syntax be removed, in favor of Proc arguments?


David

-- 
* Books:
   RAILS ROUTING (new! http://www.awprofessional.com/title/0321509242)
   RUBY FOR RAILS (http://www.manning.com/black)
* Ruby/Rails training
     & consulting:  Ruby Power and Light, LLC (http://www.rubypal.com)