Hi,

Am Montag, 09. Jul 2007, 14:39:15 +0900 schrieb Chad Perrin:
> On Mon, Jul 09, 2007 at 09:58:23AM +0900, Yukihiro Matsumoto wrote:
> > In message "Re: Yield should be renamed call_block"
> >     on Mon, 9 Jul 2007 09:10:23 +0900, Bharat Ruparel <bruparel / mercury.com> writes:
> > 
> > |I find it fascinating and quite a bit true.  However, I have to always
> > |mentally translate the keyword "yeild" to mean "call_block".
> > 
> > The "yield" keyword is used for this purpose from the ages of
> > languages for example in CLU.  So if you learn the history and the
> > culture, you will find less problem.
> > 
> > I am not going to rename it.  But in far future (3.0? maybe), the
> > keyword will be removed from the language, and you will access blocks
> > via block arguments of methods.
> 
> That sounds pretty good -- and more consistent across the language, too.

It would mess up my whole code when I had to mention the bock
parameter every time it's obvious there is one.

None of my methods is longer than 40 lines and this is a
habit I rely on every day. Pleeeease don't remove the yield
mechanism!

Bertram


-- 
Bertram Scharpf
Stuttgart, Deutschland/Germany
http://www.bertram-scharpf.de