On Mon, Jul 09, 2007 at 12:43:57PM +0900, John Joyce wrote:
> 
> On Jul 8, 2007, at 7:58 PM, Yukihiro Matsumoto wrote:
> 
> >Hi,
> >
> >In message "Re: Yield should be renamed call_block"
> >    on Mon, 9 Jul 2007 09:10:23 +0900, Bharat Ruparel  
> ><bruparel / mercury.com> writes:
> >
> >|I find it fascinating and quite a bit true.  However, I have to  
> >always
> >|mentally translate the keyword "yeild" to mean "call_block".
> >
> >The "yield" keyword is used for this purpose from the ages of
> >languages for example in CLU.  So if you learn the history and the
> >culture, you will find less problem.
> >
> >I am not going to rename it.  But in far future (3.0? maybe), the
> >keyword will be removed from the language, and you will access blocks
> >via block arguments of methods.
> >
> >							matz.
> >
> to the OP, Of course with your won individual modules/libraries  
> loaded/required, you can alias yield to be whatever isn't already  
> taken by something else. Ideas for aliases: yield_to, call_block,  
> step_out, segway, divert, fork, short_fork, lunch_break, junk_time,  
> call_junk, goto ((hehehe...))

s/segway/segue/

. . . unless those scooter things are what you had in mind in the first
place.

-- 
CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
Baltasar Gracian: "A wise man gets more from his enemies than a fool from
his friends."