On 7/4/07, Wayne E. Seguin <wayneeseguin / gmail.com> wrote:
>
> Hence would it not make more sense to name it " accumulate" which
> seems to me more explicit and intuitive?
>

You've already been given an answer as to why it's named as it is, but
if hypotethically it should be renamed, wouldn't "foldl" be more
suitable? As far as I can gather, inject is what functional
programming languages call a left fold, equivalent to the Haskell
function

foldl :: (a -> b -> a) -> a -> [b] -> a



-- 
- Simen