On 7/2/07, Daniel DeLorme <dan-ml / dan42.com> wrote:
> Is there some kind of package out there that would allow me to develop
> in ruby 1.8 while avoiding incompatibility with 1.9? Something that for
> example would:
>    define String#lines
>    warn me when I use String#to_a
>    define Kernel#funcall
>    warn me when I use Kernel#send on a private method
>    ...etc
>
> That would be quite useful.

Austin Ziegler and I were talking a while ago about how it'd be cool
to have an option like:

  ruby --warn1.9

As far as I know, such initiatives haven't taken place yet, but they'd
be quite welcome.  I want to start working on 1.9 compatibility for
some of my projects in the next couple months, to be an 'early
adopter'.