On Jun 28, 2007, at 10:30 , Vincent Predoehl wrote:

> require 'rubygems'
> require 'pricot'
> ...
>
> This situation occurs when I run the script from teh command line:
>
> ruby hpricot.rb

name the script different from the thing you are requiring... 'test- 
hpricot.rb' maybe.