On Jun 26, 2007, at 7:38 PM, Tim Hunter wrote:

> James Edward Gray II wrote:
>> On Jun 24, 2007, at 6:42 PM, Tim Hunter wrote:
>>
>>> Has anybody else encountered this problem?
>>
>> Yes.  This is the bug that hosed the Ruby Quiz software:
>>
>>   http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/256794
>>
>> That's the second time I have run into the bug too,  
>> unfortunately.  It's a pretty big issue with that release.
>>
>> It is fixed in the HEAD of Ruby's 1.8 branch, if that helps.
>>
>> James Edward Gray II
>>
> Thanks! I just hope it's not broken in the version that will ship  
> with Leopard.

Yeah, I fear that myself.  It would hurt the use of Ruby as a  
scripting language in that release a lot.

James Edward Gray II