My ri is broken too, and I *need* it since without it I do not know WTF 
I am doing, and I don't know how to fix it.

from the previous posts in thread on this:
> earlier installations (well, 1.8.2 at least) put the ri data files in one place ("site"), while the current installation has them in another ("system").
> I believe the correct place is "system".  I deleted the duplicates from "site".
Warren Seltzer replied:
> Thanx guys.  That fixed it.  I nuked the site directory and left the 
> system directory and
> both 'ri' and 'fxri' began working properly immediately.

and Anna wonders -
OK, so where is the site directory ? ( I see a ruby_site and a scite and 
a Site - is it any of these?)

my capital-S Site is
InstantRails\ruby\lib\ruby\gems\1.8\doc\rubyforge-0.4.2\ri\Site
but it only contains cdesc-Site.yaml - does this mean that my "broken 
ri" is an entirely different problem from Warren's?

ri --version
gives 1.0.1 if that helps any.

and is there a forum specific to "ruby newbie" questions, where it'd 
make sense to ask this stuff?   I hate to clog up the "ruby people who 
know what they're doing" forum with basic questions, but it would help 
SOOOOOO much to be able to ask a quick Q and get an answer, rather than 
spending 1/2 hr of my time (and too much of my sanity) digging to find 
each answer to each newbie question.

thanks
Anna
p.s. behavior: when I type "ri String" in a dos window *nothing* happens 
until I hit ctrl-c at which pt I get a flurry of "gee we got 
interrupted" msgs - starting with:
 [...]InstantRails/ruby/lib/ruby/1.8/rdoc/ri/ri_cache.rb:57 in 
'load_from': Interrupt

?


-- 
Posted via http://www.ruby-forum.com/.