[this message is crossposted to the Cygwin- and RubyTalk mailing lists].

Running Ruby 1.8.6 under Cygwin, i.e.


 $ /usr/bin/ruby --version
 ruby 1.8.6 (2007-03-13 patchlevel 0) [i386-cygwin]

the statement

  require 'mysql'

raises the following error message:

/usr/lib/ruby/gems/1.8/gems/mysql-2.7.3-mswin32/ext/mysql.so: Permission
denied - /usr/lib/ruby/gems/1.8/gems/mysql-2.7.3-mswin32/ext/mysql.so
(LoadError)
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `require'

The access rights to mysql.so are as follows:


-rw-r--r-- 1 rfischer mkgroup-l-d 81984 May 21 18:08
/usr/lib/ruby/gems/1.8/gems/mysql-2.7.3-mswin32/ext/mysql.so


Using the mysql module with Ruby on Windows outside Cygwin works well.
What could be the reason for this problem?

Ronald

-- 
Ronald Fischer <ronald.fischer / venyon.com>
Phone: +49-89-452133-162