> I haven't unmerged them. However, the newly built ruby does not have
> the gems, only the system one does.

Hmm, then it should work.  The easiest workaround is to just "unset RUBYOPT" from
the command line.  I guess your installed "test" version of Ruby just doesn't know
where to find extra system ruby files.

Caleb