Hello there.

Well, I've installed hpricot using gem, and it works well in windows.
But under my fedora 7, although gem told me that hpricot has been
successfully installed(I did install gcc and make so that gem can
compile the source code), I still can't load it into my program. Under
irb, it just told me that 'no such file to load hpricot' when I type
"require 'hpricot'".

I've also installed rails using gem under Linux. If I type 'rails -v'
directly into the terminal, it works and told me it's 'rails 1.2.3', but
"require 'rails'"(I don't know whether it'll work. Just to have a try)
in irb won't work too, just like hpricot.

"ri hpricot" won't work too.

I can find hpricot and rails under '/usr/lib/ruby/gems/1.8/gems'. But it
seems the ruby won't load libs in it.

What should I do~~~~

-- 
Posted via http://www.ruby-forum.com/.