On Mon, Jun 04, 2007 at 02:46:55AM +0900, Eleanor McHugh wrote:
> 
> Well as I said in my original post, %$ was intended purely as a  
> placeholder. I did also consider <= which could play an analogous  
> role to => in hash literals but it looked even stranger. Another  
> possibility would be:
> 
> 	return f(x) if != y
> 	return f(x) unless == y
> 
> which would complicate the parser but is quite readable.

Unfortunately for the <= idea, <= means "less than or equal to" as a
comparison operator already.  I do like the readability of your return
statement syntax, though.

-- 
CCD CopyWrite Chad Perrin [ http://ccd.apotheon.org ]
Paul Graham: "Real ugliness is not harsh-looking syntax, but having to
build programs out of the wrong concepts."