Dear all,

I am trying to get Jeff Mitchell's linalg package
to work on my machine (OpenSuse 10.2 on i586).
I installed the linalg-0.3.2-i686-linux-ruby18.tgz package,
apparently successfully (that's what my computer told me),

but when I try to actually use it, I get:

>require "linalg"

/usr/local/lib/ruby/site_ruby/1.8/x86_64-linux/lapack.so: /usr/local/lib/ruby/site_ruby/1.8/x86_64-linux/lapack.so: wrong ELF class: ELFCLASS32 - /usr/local/lib/ruby/site_ruby/1.8/x86_64-linux/lapack.so (LoadError)
	from /usr/local/lib/ruby/site_ruby/1.8/linalg.rb:7
	from test.rb:1:in `require'
	from test.rb:1

I also tried to compile the other linalg.tgz package from source,
but there, the system misses f2c, and can't be told to find it in
/usr/bin, or to compile with the flag --without-libf2c .

Thank you for any help.

Best regards,

Axel 
-- 
GMX FreeMail: 1 GB Postfach, 5 E-Mail-Adressen, 10 Free SMS.
Alle Infos und kostenlose Anmeldung: http://www.gmx.net/de/go/freemail