On Wed, May 23, 2007 at 12:39:52AM +0900, Fred Phillips wrote:
> I only have:
> ftp.rb  http.rb  imap.rb  pop.rb  protocol.rb  smtp.rb  telnet.rb
> 
> in my net/ directory

So, let me guess - you're using Ubuntu or Debian, right? If so you'll need

# apt-get install libopenssl-ruby1.8

If not, then please describe your system.

(Aside: This really belongs in a FAQ.
  1. Always state exactly what system you're running under.
  2. If running Debian/Ubuntu, Ruby is broken into shrapnel packages)