On 22.05.2007 00:58, Trans wrote:
> 
> On May 21, 6:10 pm, Robert Klemme <shortcut... / googlemail.com> wrote:
>> On 21.05.2007 19:52, Trans wrote:
>>
>>> So I take it you actually mean that using to_enum is better in that
>>> you don't need to know anything about #range to understand the code?
>> Exactly.
>>
>>> I can understand, but I think its preferable to break things down into
>>> smaller, more readable, sub-functions.
>> Um, I am not sure I understand what you mean by this in the current
>> context.  Can you please elaborate?
> 
> Hmmm... The best answer I can probably give is actually this:
> 
>   http://thinking-forth.sourceforge.net/
> 
> Sorry it's not a concise answer, but this conversation could very well
> EXPLODE from here. And I'd prefer to keep DRY ;-)

Frankly, I won't be reading a 300+ page document in order to try to get 
an idea of what you /might/ have intended.

Kind regards

	robert