i have been trying to install Ruby-WordNet, to no avail ... :(

I am on a Mac, and I am pretty sure that bdb is already installed by  
default on Tiger.  I downloaded WordNet 3.0, and fed its 'dict'  
directory path to convertdb.rb, but I get an error:

Dan$ ruby convertdb.rb /usr/local/WordNet-3.0/dict
/Users/Dan/Desktop/Ruby-WordNet-0.02/lib/wordnet/lexicon.rb:32:in  
`require': no such file to load -- bdb (LoadError)
         from /Users/Dan/Desktop/Ruby-WordNet-0.02/lib/wordnet/ 
lexicon.rb:32
         from /Users/Dan/Desktop/Ruby-WordNet-0.02/lib/wordnet.rb: 
82:in `require'
         from /Users/Dan/Desktop/Ruby-WordNet-0.02/lib/wordnet.rb:82
         from convertdb.rb:38:in `require'
         from convertdb.rb:38

Any advice would be appreciated (especially a suggestion for a easier/ 
newer way to have my Ruby program retrieve word synonyms)

Best,
DAN


On May 9, 2007, at 11:25 PM, Marcel Molina Jr. wrote:

> On Thu, May 10, 2007 at 12:22:52PM +0900, blufur wrote:
>> Hi all. I'm writing a Ruby program that requires a thesaurus to
>> expand a given term to a set that includes all its synonyms... anyone
>> know of a resource that I can have my program access?
>
> http://www.deveiate.org/projects/Ruby-WordNet/
>
> marcel
> -- 
> Marcel Molina Jr. <marcel / vernix.org>
>