Does anybody have suggestions on where is best to install ruby-dbi??
There seems to be no gem version at this time and I do want to keep  
things clean if I can.

My local machine is set up like so:
OS X 10.4.9

Ruby 1.8.4  in:
/usr/local/bin/ruby