Hmm... in the directory
/usr/local/lib/ruby/gems/1.8/gems/

There is indeed the gem as listed, and an html readme file!
/usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/README.html

It isn't the best documentation, but leads to some conclusions that I  
do indeed need to re-install the gem or at least configure it.
The options for step 1 are a bit sparsely explained.
ANY advice on the options for extconf.rb would be greatly appreciated.

You guys are right!
It is a bad install.

I didn't know Rails shipped with its own mysql drivers. That is an  
interesting thing to know though.

I took a look at the mkmf log file and sure enough, it has as many  
errors as the moon has craters! (that's a lot of holes)
I had the same trouble with BlueCloth before.

I do wish gems would fail to install if they're not properly install.  
This is definitely a cause for many posts from Rails people.
On OS X at least, this may be less of a trouble with the next version  
of the OS, since it should have much of these things installed in a  
good way. (we'll see ...)

But I can blame mysql as well. It isn't the most friendly install  
either.

I just hope this doesn't turn into one of those all day installs that  
leads me learning more about mysql internals than I want to know...