Hello all,

i just got the office source distribution of 1.8.6 to compile into a 
.lib with visual studio 2005 (vc8) using the nmake method... it worked 
very well, i only ran into one problem which trying to compile it with 
the -MDd debug runtime here:

bigdecimal.c line 1958:

static int gfDebug = 1;         /* Debug switch */

that was commented out which caused the build to fail... simple fix though.

So, my question is this: I have linked the interpreter into my VC++ 
project successfully, but when I try to have a ruby script use ext's 
like "stringio" it throws an error.  any idea how i could get this 
embedded ruby interpreter to load ext's? 

i'm using the msvcr80-ruby18-static.lib and compiled it with "configure 
--with-static-linked-ext"

in particular i mean "require 'stringio'" just returns an error that 
says "no such file to load - stringio" ... 

anyhow, if you have any insight i appreciate it

-Josh

-- 
________________________________________________________________
tasty electronic music vittles      --  bluevitriol.com
the only music blog you need        --  playtherecords.com
you are the dj.  interactive music  --  improbableorchestra.com
random observations of the bizarre  --  vitriolix.com