Jeffrey 'jf' Lim wrote:
> hi, folks, I have been hacking away at this thing for a number of
> hours now, and have found no solution. I have absolutely no idea what
> happened here, but I do know for a fact that this has always been
> working all along. I have ruby (from source), sqlite (from source),
> gems, and the sqlite3-ruby gem installed, but try as I might, i keep
> hitting into this error. What's wrong?
> 
> ==========
> 
> # ruby -e "require 'sqlite3'"
> -e:1:in `require': no such file to load -- sqlite3 (LoadError)

Have you set RUBYOPT in your environment?
If not, have you tried to use "require 'rubygems'"?
Are your permissions for the gem directory correct? (They probably are, 
as rails still works.)
Have you checked how rails invokes sqlite3?

I have sqlite3 working on Windows and Ubuntu Linux 6.10, and have hit 
that only when I forgot to load rubygems beforehand.

-- 
Phillip "CynicalRyan" Gawlowski
http://cynicalryan.110mb.com/

Rules of Open-Source Programming:

22. Backward compatibility is your worst enemy.

23. Backward compatibility is your users' best friend.