Dear Experts.

I come from LEAF user community.

I'm a damn stupid newbie about RUBY.
I just impresed by someone who post about how easy to write a JABBER client
using ruby.

Since I come from a community of users of Small linux distro, my concern is
about a micro Ruby "distro" (maybe like Micro Perl)

So Here is my question :

1. Is there anyone can give me a list of extremely minimal files that have
to be compiled to got ruby core interreter work properly ?
2. What is the minimal libs have to be loaded/compiled to write :
++ Jabber client
++ BASH similar : Cat, Cut, sed

I'm intended to compile of that minimal files with uCLib .. and may be
create a "*.lrp" package for the LEAF community.

Sincerely
-bino-