2007/3/27, Wolfgang NĂ¡dasi-Donner <wonado / donnerweb.de>:> The library should support Oniguruma-4 versions, because they will be used in> Ruby, starting with version 1.9, while Oniguruma-5 is not related to Ruby. If> one wants to use the pattern matching capabilities of Ruby 1.9, but still have> problems with libraries, that are not yet ported to Ruby 1.9, needs the regular> expression engine of Ruby 1.9 in Ruby 1.8 to avoid later porting problems for> the own software.>
Hi, Wolfgang!
As for me, the most notable difference between 4.x and 5.x versions ofOniguruma is extended support for Unicode in the latter, especiallycasefolding for full character repertoire. The only definition missingis for CP1251 encoding (just comment it out in source and build foryour own:), yep, that #ifdef perhaps should be in 1.0.1 release ),rest of the code does not rely on some special features of 5.x missingin 4.x series.
Next, Ruby 1.9 is a moving target, so before the great day of 2.0appearance (that is really soon, at least one year from now, though),several changes can happen, and  even now there can be otherdiscrepancies with regexp usage in 1.9 and "oniguruma for ruby" (ifyou find out them, drop a note to rubyforge tracker for the project).
Besides, I expect some compilation failures with microsoft visual Ccompilers, but don't have one at present, so if you find problems withthat, please report.
WBR,Nikolai, co-developer of Oniguruma for Ruby.