--0-424150215-11746575029834
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

>Trans <transfire / gmail.com> wrote: 
  >But if they've got to stay, please, at least consider renaming them
>something like class_public and class_private.

  
>Paul Stickney <pstickne / gmail.com> wrote:
  >matz, your example was so elegantly simple that I want to say you have
>my vote to just drop the methods in question--at least from core.
>There is plenty of Java to go around already.

   
  I totally agree. If the current two utility methods are to stay in the Ruby core, please :
  - add the missing one for protected visibility
  - change the naming of these methods for removing the confusion
  for the overall consistency.
   
  Otherwise, just remove the 2 existing methods.
   

 
---------------------------------
Expecting? Get great news right away with email Auto-Check.
Try the Yahoo! Mail Beta.
--0-424150215-11746575029834--