I installed Ruby, Gems, Rails etc. following the instructions on
http://hivelogic.com/narrative/articles/ruby-rails-mongrel-mysql-osx
(Me: using Intel, 10.4, all other settings and versions same as that
website)

Gems was working as I was able to install Rails, Mongrel, Capistrano
and MySql bindings, and I was able to make a test app, and start it
using script/server
This was sometime last week

Now, I wanted to do some tutorials today, but I wasn't able to invoke
script/server I got error:

/usr/local/bin/gem:9:in `require': No such file to load -- rubygems
(LoadError)
        from /usr/local/bin/gem:9

I found out that I got the same error with anything that requires
gems. i.e. gem install rails. I even reinstalled Gems but that didn't
help.

Any ideas on how I could get this working again? Thanks