Hi All,

I'm not able to start webrick server on my system. Here I'm giving that
error which occures during start the webrick.


C:\myapp>ruby script/server
./script/../config/boot.rb:28:Warning: require_gem is obsolete.  Use gem
instead
.
=> Booting WEBrick...
c:/ruby/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 17, col
2: `  h
ost: localhost' (ArgumentError)
        from c:/ruby/lib/ruby/1.8/yaml.rb:133:in `load'
        from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:459:i
n `database_configuration'
        from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:181:i
n `initialize_database'
        from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:84:in
 `process'
        from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:42:in
 `send'
        from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:42:in
 `run'
        from ./script/../config/../config/environment.rb:13
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
         ... 7 levels...
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
        from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `re
quire'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in `require'
        from script/server:3

-- 
Posted via http://www.ruby-forum.com/.