Maybe a dumb question but do you have a PPC Mac? I had a bunch of  
similar errors when I migrated my entire system (including Ruby  
install) from my PPC Powerbook Pro to an Intel MacBook Pro. The  
resolution was a complete reinstall of Ruby.

Peter

On Mar 20, 2007, at 8:20 AM, Une B?vue wrote:

> i'm using ruby with libxml and libxslt to transfom an xhtml file  
> into an
> xbel one thru xslt.
>
> It seems (not deeply verified) the transform itself works but i get  
> the
> following error message :
>
> $ ./fir2xbel.rb
> ./fir2xbel.rb:23: [BUG] Bus Error
> ruby 1.8.5 (2006-08-25) [powerpc-darwin8.8.0]
>
> the whole script could be resumed to :
>
> #! /usr/bin/env ruby -wx
>
> require 'xml/libxml'
> require 'xml/libxslt'
>
> xslt=XML::XSLT.file(<xsl file>)
> xslt.doc=XML::Document.file(<xml file>)
> s=xslt.parse
> s.apply
> f=File.open(<xbel file>,'w')
> f.puts s
>
> notice the -wx arg to Ruby.
>
> where could i search for such an error ?
>

Peter Booth
peter_booth / mac.com
917 445 5663