I am using the rubyzip library now- it works fine.

On Mar 14, 10:05 am, Clifford Heath <n... / spam.please.net> wrote:
> greg wrote:
> > ruby -rzlib-e 'putsZlib::ZLIB_VERSION'
> > 1.2.3
>
> I recall having had that problem a year or two ago.
> I think it was fixed by a version update, but I don't
> know the version numbers any more. It was definitely
> a bug inzlibthough, and I definitely got around it
> without having to patch the source.
>
> Sorry I can't help more right now.
>
> Clifford Heath.