On 3/8/07, Hanan Mneimneh <hanan_mneimneh / hotmail.com> wrote:
> Hello
>
> I installed open4, but when i tried samples I got the following error:
> uninitialized constant fcntl::F_SETFD. why???  please note that I am working
> on windows.
> Thank in advance
>

open4 will not work on Windows -- it is a Unix only library.For
Windows there is popen4.

http://rubyforge.org/projects/popen4/

It does the same thing ... but for Windows.  Be forewarned that the
possibility of blocking the program on a full pipe is very possible on
the Windows platform. Ara and Tom Pollard had a good discussion about
this last Thanksgiving.

http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-core/9379

Blessings,
TwP