Thanks for the help both of you!  I ended up using the method James 
proposed (it was cleaner ;) ).

Very interesting thread too.  From a usability standpoint, adding a 
raises method to TestCase seems to provide the most intuitive syntax... 
at least for me it does.  Can't wait to see how things pan out!

-- 
Posted via http://www.ruby-forum.com/.