Trans wrote:
> Now I've always felt the methods, public_methods, private_methods and
> protected_methods and singleton_methods were quite wasteful. One
> method would suffice for all five, this has been discussed before. And
> if we went ahead and did that and called that method #object_methods

I kinda like that a little bit. We could have
   foo.object_methods.all/to_a
   foo.object_methods.private
   foo.object_methods.protected
   foo.object_methods.public
   foo.object_methods.singleton

But I'm not too concerned with "clutter". A basic Object could have a 
bazillion methods as far as I care, as long as they don't conflict with 
methods names that people can reasonably/possibly create on their own. 
"private_methods" already has the adjective "private" to qualify the 
ambiguous noun "methods", so changing that adjective to "object" is not 
much of an improvement. Adding an adjective to "methods" would be good 
but that is already done; methods is just an alias of public_methods.

Daniel