For the record, I find a few of Ruby's naming choices silly and
non-intuitive as well.  "elsif", regardless of it's language lineage,
IS kinda weird and easy to miss.  "case" should have been "switch".
And almost any of the proposed alternatives to "inject" would be
preferable - with my personal preferance being "fold".

But I'm so used to dealing with language eccentricities, and Ruby's
features give me so much joy, that it's easy to overlook such
nitpicks.

--
Avdi